Branche modeles

Les propositions de correctifs ou d'exercices pour Pyromaths.

Modérateur : Développeurs

Avatar de l’utilisateur
Jérôme
Administrateur - Site Admin
Messages : 1130
Inscription : 26 août 2006, 13:10
Localisation : Nantes
Contact :

Re: Branche modeles

Message par Jérôme » 24 août 2009, 01:12

Pas de soucis.
Pyromaths génère des fiches d'exercices et leur corrigé en toute simplicité.
Un programme multi-plateformes libre et gratuit sous licence GPL

Avatar de l’utilisateur
Arnaud
Critique officiel de pyromaths
Messages : 609
Inscription : 26 août 2006, 21:49
Localisation : Allemagne
Contact :

Re: Branche modeles

Message par Arnaud » 24 août 2009, 12:47

Correction : 6e et 3e sont écrits de la même façon, ainsi que 5e et 4e.
C'est original :)

Les quatre niveaux sont activés, et cela fonctionne sous ma debian sid.
Sous xp virtualisé, même problème d'encodage : "dvips can't be opened", mais c'est peut-être parce que j'ouvre des fichiers partagés sur le réseau en utf8.

C'est à jour sur le git en attendant. Faudrait également tester sous mac.

A propos des modèles, faudrait trouver des noms plus explicites que modele1, etc...

Avatar de l’utilisateur
Arnaud
Critique officiel de pyromaths
Messages : 609
Inscription : 26 août 2006, 21:49
Localisation : Allemagne
Contact :

Re: Branche modeles

Message par Arnaud » 25 août 2009, 16:27

Allons-y :

- j'ai modifié la chose pour que les modèles soient copiés dans le "configdir" + /modeles
- comme du coup j'ai besoin de la variable configdir, je l'ai ajoutée au dictionnaire parametres
- au lieu d'utiliser dircache, j'utilise os.lisdir, cela semble suffire, cela fait déjà un module en moins
- tu te réjouissais déjà, ben on utilise un module en plus pour copier : shutil, avec sa fonction copy2 qui a l'avantage de copier les dates, etc...
- dans interface, la liste des modèles est dorénavant faite à partir de "configdir" + /modeles, et si le "count" est à 0, j'ai mis un print "message d'erreur", car je ne sais plus faire une "errorbox" sous qt4
- testé sous debian, ça tourne sans problème
- sous win, l'initialisation des modèles se passe sans soucis, mais toujours le problème de compilation, mais bon, comme j'ai plusieurs versions de Qt et de python installées, on va dire que c'est normal, j'essayerai avec la version compilée.

Répondre