Page 1 sur 2

Version 14.06

Publié : 11 juin 2014, 12:09
par Jérôme
Je suis prêt à publier une version 14.06 avec un nouvel exercice que j'aime bien, sur la notion de fonction en 3e. Il est accessible sur Pyromaths en ligne. Je pense le faire d'ici la fin de semaine. Yves, je ne pense plus toucher au Git d'ici là, si tu veux préparer la version en avance :)

Par ailleurs, il y avait un méchant bug sur la version en ligne : quand on demandait plusieurs versions d'un même exercice, on obtenait le même exercice en plusieurs exemplaires... Ce qui limite tout de même beaucoup l'intérêt de Pyromaths. Ce qui m'ennuie le plus, c'est que personne n'a pris le temps de le signaler, alors que je suis certain que plusieurs utilisateurs s'en sont nécessairement aperçu. :? C'est dommage.

Re: Version 14.06

Publié : 11 juin 2014, 12:43
par Yves
Le nouvel exercice est vraiment très bien, bravo Jérôme !

Au fait, est ce que tu as bien reçu la réponse de Didier Roche que je t’avais renvoyée fin mai ?

La version 14.06 pour OS X est prête:
http://www.pyromaths.org/telecharger/py ... -macos.dmg

Re: Version 14.06

Publié : 11 juin 2014, 13:44
par Jérôme
Quelle efficacité ! :) Merci beaucoup Yves.

J'ai bien reçu la réponse de Didier. Cependant, je n'ai pas bien compris le concept. J'ai sans doute tout lu trop vite. Je tenterai d'y passer un peu plus de temps.

Par ailleurs, je ne reçois plus les notifications par mail non plus. je tenterai de regarder pourquoi un peu plus tard.

Re: Version 14.06

Publié : 11 juin 2014, 14:42
par Yves
Réaliser le packaging pour OS X va très vite, je lance un script qui récupère les sources, exécute la commande make et crée l'image disque. Après, il a fallu 17 pages sur le fil Packaging pour en arriver là :P

J'ai mis à jour «Développer une application autonome sur OS X 10.9» dans la documentation avec les dernières modifications et versions utilisées. Lorsqu'on modifie un article, les sauts de ligne ne sont pas toujours mémorisés, ce qui casse la mise en page.

Re: Version 14.06

Publié : 11 juin 2014, 16:12
par Jérôme
Oui, ça ne fonctionne aps très bien. Je regarderai si je peux remplacer l'éditeur pour obtenir du html. Je sais que ça te ferait plaisir. :)

Re: Version 14.06

Publié : 11 juin 2014, 18:18
par Yves
Je viens de regarder le code source de la page avec l'éditeur. La plupart des scripts javascripts ou feuille de style CSS, appelés dans l'en-tête, ont une adresse qui n'est pas valide, ce qui explique les dysfonctionnements actuels.

L'éditeur utilisé actuellement, c'est markItUp! avec le language Textile. D'après leur site web, on peut aussi utiliser markItUp! avec du html.

Re: Version 14.06

Publié : 12 juin 2014, 18:43
par Jérôme
merci Yves pour ta recherche. J'ai effectué les modifications nécessaires sur le serveur Apache. Tout est rentré dans l'ordre. J'ai remis les sauts de lignes nécessaires dans ton article et je crois qu'il est à présent tout beau. :)

Re: Version 14.06

Publié : 12 juin 2014, 21:38
par Yves
Merci Jérôme. C'est beaucoup mieux !

Il reste quelques petits soucis, les sauts de lignes ne sont pas mémorisés (il faut les remettre à la main à chaque nouvelle édition de l'article) et les balises de titre en Textile ne sont pas reconnues (h4. par exemple) :

Image

Re: Version 14.06

Publié : 12 juin 2014, 22:42
par Jérôme
C'est corrigé. J'avais ajouté une application au sein de Django qui supprimait les lignes vides dans les pages html générées. Je trouvais ça plus joli... Mais ça met le bazar dans textile. Je l'ai donc virée.
Je cherche toujours à comprendre l'origine de mes problèmes avec les mails.

Re: Version 14.06

Publié : 12 juin 2014, 22:54
par Yves
Merci pour cette correction !

Tant qu'on y est, un autre soucis:

Le lien http://forum.pyromaths.org (accessible depuis la page d'accueil) ne renvoie pas sur index.php et un message générique est affiché à la place du forum !

Re: Version 14.06

Publié : 12 juin 2014, 23:06
par Jérôme
Alors là, je suis embêté, car ce n'est pas le cas chez moi...

Re: Version 14.06

Publié : 12 juin 2014, 23:18
par Jérôme
Peux-tu me dire si c'est corrigé ? Et si tu reçois les mails ?
Merci

Re: Version 14.06

Publié : 12 juin 2014, 23:28
par Yves
J'ai vidé le cache de mon navigateur et il n'y a plus de soucis ! Autant pour moi. Pour les mails, je n'ai rien eu pour l'instant.

Re: Version 14.06

Publié : 12 juin 2014, 23:30
par Jérôme
"Au temps pour moi", il me semble. J'ai bien modifié la configuration du serveur également, c'est donc peut-être pour cela que ça fonctionne à présent (sans doute même).
Quant à moi, j'ai reçu un mail m'informant que tu avais posté un message. je vais donc me coucher heureux ! :)

Re: Version 14.06

Publié : 13 juin 2014, 08:37
par Yves
Apparemment, les deux possibilités existent…

Je viens de réaliser que je ne surveillais pas ce sujet :oops: si tu as reçu un mail, c'est que tout fonctionne à nouveau ! Bravo pour ce correctif.