Python: version cible?

Les propositions de correctifs ou d'exercices pour Pyromaths.

Modérateur : Développeurs

Avatar de l’utilisateur
djinn
Messages : 183
Inscription : 03 mars 2013, 10:38

Python: version cible?

Message par djinn » 23 mars 2013, 11:13

Bonjour,

Je suis entrain de relire le manuel python histoire de me rafraîchir un peu la mémoire. Je vois notamment quelques nouveautés dans python 2.7, dont certaines (comme le module argparse par exemple) pourraient m'être utile…
Avec quelle version de python pyromaths doit-il maintenir une compatibilité? Puis-je utiliser des nouveautés de la version 2.7?

Avatar de l’utilisateur
djinn
Messages : 183
Inscription : 03 mars 2013, 10:38

Re: Python: version cible?

Message par djinn » 23 mars 2013, 11:26

Je vois dans la description du paquet Debian: python 2.5 à python 2.7…

Avatar de l’utilisateur
Jérôme
Administrateur - Site Admin
Messages : 1083
Inscription : 26 août 2006, 13:10
Localisation : Nantes
Contact :

Re: Python: version cible?

Message par Jérôme » 23 mars 2013, 15:19

Debian Squeeze est en Python 2.6.6. par conséquent, pyromaths ne peut aller au delà. Désolé...
Pyromaths génère des fiches d'exercices et leur corrigé en toute simplicité.
Un programme multi-plateformes libre et gratuit sous licence GPL

Avatar de l’utilisateur
djinn
Messages : 183
Inscription : 03 mars 2013, 10:38

Re: Python: version cible?

Message par djinn » 23 mars 2013, 15:34

Bien reçu. Merci. :-)

Répondre