SIP & PyQt 4.6

Les propositions de correctifs ou d'exercices pour Pyromaths.

Modérateur : Développeurs

Avatar de l’utilisateur
Arnaud
Critique officiel de pyromaths
Messages : 609
Inscription : 26 août 2006, 21:49
Localisation : Allemagne
Contact :

SIP & PyQt 4.6

Message par Arnaud » 27 sept. 2009, 20:04

Impossible de l'installer sur Jaunty en VB : j'obtiens une tonne d'erreurs rien que pour SIP.
Jérôme, tu pourrais tester et me dire ?

PyQt est en 4.4 par défaut.

Avatar de l’utilisateur
Jérôme
Administrateur - Site Admin
Messages : 1130
Inscription : 26 août 2006, 13:10
Localisation : Nantes
Contact :

Re: SIP & PyQt 4.6

Message par Jérôme » 27 sept. 2009, 20:22

Sous jaunty,

Code : Tout sélectionner

sudo apt-get install python3-dev
cd sip-4.9
python3.0 configure.py
make
sudo make install
cd PyQt-x11-gpl-4.6
python3.0 configure.py
make -j5 (j'ai un QuadCore ! :D mais c'est tout de même très long)
sudo make install
Et voilà, c'est fait.
Pyromaths génère des fiches d'exercices et leur corrigé en toute simplicité.
Un programme multi-plateformes libre et gratuit sous licence GPL

Avatar de l’utilisateur
Arnaud
Critique officiel de pyromaths
Messages : 609
Inscription : 26 août 2006, 21:49
Localisation : Allemagne
Contact :

Re: SIP & PyQt 4.6

Message par Arnaud » 27 sept. 2009, 20:39

C'était un problème de locales ( je ne prends jamais le temps de configurer les sous-distributions :D ).

Sinon, pour Pyqt, j'ai le message suivant :

Code : Tout sélectionner

make -j5 (j'ai un QuadCore ! :D mais c'est tout de même très long)
PyQt error : Unknown option "(j'ai" 










































:mrgreen:
Nan, ça a l'air de compiler, merci ;)

Répondre