Page 1 sur 1

Crash avec BasicTeX2019 et Pyromaths 1.9.3 sous macOS 10.15

Publié : 05 janv. 2020, 11:14
par ChristianEdu
Bonjour... et bonne année !

Comme chaque année, je prépare pour nos classes genevoises une future configuration macOS (en 10.15) avec Pyromaths et cette fois BasicTeX2019.

Après avoir installé BasicTeX 2019 et Ghostcript 9.50, j'ai lancé les commandes vues dans la Documentation du site de Pyromaths (les commandes vues dans le post https://forum.pyromaths.org/viewtopic.php?f=19&t=445).
Hélas, je n'ai qu'un fichier exercices.tex produit et Pyromaths crashe.
A nouveau, j'ai besoin d'un coup de main pour rendre l'utilisation de Pyromaths possible.

Pour gagner du temps par rapport à l'année passée, j'ai passé la commande "latex exercices.tex" dans le terminal. J'ai placé le résultat de cette commande, plus le log de crash plus le fichier exercices.tex dans une archive zippée https://www.dropbox.com/s/kifh2zr5vbhtm ... s.zip?dl=0

Merci d'avance

Christian

Re: Crash avec BasicTeX2019 et Pyromaths 1.9.3 sous macOS 10.15

Publié : 05 janv. 2020, 12:00
par ChristianEdu
Un 2e essai avec l'installation de texonlive ne donne pas de meilleurs résultats, Pyromaths crashe toujours

Re: Crash avec BasicTeX2019 et Pyromaths 1.9.3 sous macOS 10.15

Publié : 05 janv. 2020, 12:35
par ChristianEdu
... et je viens de vérifier avec une installation complète de MacTeX 2019, Pyromaths fonctionne correctement.

Re: Crash avec BasicTeX2019 et Pyromaths 1.9.3 sous macOS 10.15

Publié : 05 janv. 2020, 13:29
par Yves
Bonjour,

1. Sur le bureau d'un ordinateur avec BasicTex2019, copier un fichier exercice.tex (obtenu avec une installation fonctionnelle de Pyromaths).

2. Ouvrir le Terminal et exécuter les instructions suivantes:

Code : Tout sélectionner

cd Desktop; latex ~/Desktop/exercices.tex
Les erreurs obtenues devraient indiquer quel paquet manque.

3. Installer ce paquet (remplacer pkgname par le nom du paquet):

Code : Tout sélectionner

sudo tlmgr install pkgname
4. Répéter les étapes 2 et 3 jusqu'à obtention d'un fichier exercice.dvi.

4. Pyromaths devrait fonctionner avec BasicTex2019 !

Re: Crash avec BasicTeX2019 et Pyromaths 1.9.3 sous macOS 10.15

Publié : 05 janv. 2020, 16:45
par ChristianEdu
Bonjour Yves,

Merci de la réponse rapide.

J'avais fait tout ceci... mais je l'ai refait sur une config 10.15.2 propre, avec une installation de BasicTeX 2019 et les commandes passées dans la Documentation du site. J'ai lancé la commande

Code : Tout sélectionner

latex ~/Desktop/exercices.tex

Dans la liste des lignes produites il n'y avait pas d'indication d'un paquet manquant.
Et Pyromaths fonctionne...

Je ne comprends pas vraiment ce qui a changé depuis mes premiers essais et je vais encore vérifier en faisant une installation à distance avec nos nouveaux outils de déploiement (Jamf), mais cela m'a l'air prometteur.

Merci du coup de main

Christian

PS Dans la documentation, on pourrait adapter pour la version 2019, en remplaçant dans les 2 commandes 2018 par 2019.