Page 1 sur 1

Version 18.9

Publié : 03 sept. 2018, 18:44
par Jérôme
La version 18.9 est enfin prête. Elle est en ligne sur https://enligne.pyromaths.org, elle est disponible sur le ppa de pyromaths.

La grande nouveauté, ce sont les paquets pyromaths et pyromaths-qt séparés, ainsi que le passage à Python 3.5.

Yves, si tu as la possibilité de préparer le paquet MacOS dans les prochains jours, ce serait super.

Louis, je n'ai pas les droits pour uploader Pyromaths sur Pypi.

Je remercie Louis encore une fois pour son énorme investissement durant les vacances.

Jérôme

Re: Version 18.9

Publié : 08 sept. 2018, 11:07
par Yves
Pyromaths 18.9 est disponible pour macOS :)
https://www.pyromaths.org/downloads/pyr ... -macos.dmg

Re: Version 18.9

Publié : 08 sept. 2018, 11:41
par Jérôme
Merci beaucoup Yves. C'est en ligne.

Une remarque pour l'avenir : le numéro de version de ton fichier correspond à la version de Pyromaths-QT, et pas à Pyromaths. Or Pyromaths-QT va évoluer moins vite que Pyromaths. Je crois donc qu'à l'avenir, il faudrait modifier cela (je ne sais pas si je suis très clair).

Il ne reste plus qu'à Louis de me donner un accès au pypi et Pyromaths sera à jour partout.

Bon week-end.

Re: Version 18.9

Publié : 08 sept. 2018, 15:10
par Yves
Jérôme, pyromaths-18.9.3-macos n'apparaît pas dans la page de téléchargement.

Si les numéros de version vont évoluer séparément, il faut effectivement que le numéro de version de Pyromaths.app corresponde à la version de Pyromaths.

Pour être cohérent, il faudrait également que dans la boîte de dialogue "À propos" le numéro de version soit celui de Pyromaths. Or, pour l'instant, il est issu de pyromaths-qt/pyromaths/qt/version.py. Qu'en penses-tu ?

Re: Version 18.9

Publié : 08 sept. 2018, 17:54
par Jérôme
Je pense que tu as un problème de cache. Le site est https://www.pyromaths.org

Concernant la boite de dialogue, tu as raison. il faudrait indiquer les deux versions.

Re: Version 18.9

Publié : 08 sept. 2018, 18:49
par Yves
Oui, j'ai du voir une page en cache…
Jérôme a écrit :
08 sept. 2018, 17:54
Concernant la boite de dialogue, tu as raison. il faudrait indiquer les deux versions.
Idem pour la version de l'application (indiquée par exemple sur macOS par le Finder et aussi dans "Lire les informations")
Pour l'instant c'est le numéro de version de Pyromaths-QT qui est récupéré via setup.py et qui est affiché par le Finder. Par contre, dans le Finder, il n'est pas possible d'afficher deux numéros.

Re: Version 18.9

Publié : 09 sept. 2018, 18:25
par Yves
Il faudrait éditer la page (je n'ai plus d'accès) :
https://www.pyromaths.org/installer-pyr ... cos-x.html

Configuration requise: Pyromaths nécessite macOS version 10.10 ou ultérieure.

Re: Version 18.9

Publié : 09 sept. 2018, 18:36
par Jérôme
Je l'ai effectué. Ce sera mis à jour lorsque j'aurais fini mon bricolage.
Par ailleurs, le site est actuellement sur FramaGit. Tu y as donc accès. ;)

Re: Version 18.9

Publié : 09 sept. 2018, 19:34
par Yves
Merci Jérôme.