Page 1 sur 1

Problème de compliation latex

Publié : 15 mars 2016, 17:28
par MikFich
Bonjour,

Tout d'abord merci pour le travail effectué.

J'ai installé la dernière version sous windows sans problème, lorsque je crée une feuille d'exos tout se passe bien, le pdf est généré. Par contre j'ai un bug lorsque je recompile le fichier .tex (le but étant de changer la langue des intitulés des exercices). Ce problème apparaît même lorsque le fichier n'a pas été transformé.

J'utilise la version 2015 de TexLive.

Voici les messages du log :

Code : Tout sélectionner

c:/texlive/2015/texmf-dist/tex/latex/hyperref/hyperref.sty:4319: Package hyperref Error: Wrong DVI mode driver option `ps2pdf', [\ProcessKeyvalOptions{Hyp}]
./exercices.tex:125: Undefined control sequence. [...uler $HD$ et $HB$, arrondies au dixième}]
c:/texlive/2015/texmf-dist/tex/latex/etex-pkg/etex.sty: Package etex Warning: Extended allocation already in use.
./exercices.tex:128: LaTeX Warning: Reference `LastPage' on page 1 undefined on input line 128.
./exercices.tex: Package rerunfilecheck Warning: File `exercices.out' has changed.
./exercices.tex: LaTeX Warning: There were undefined references.
./exercices.tex: LaTeX Warning: Label(s) may have changed. Rerun to get cross-references right.
Merci pour votre aide.

Mikael

Re: Problème de compliation latex

Publié : 16 mars 2016, 14:31
par Jérôme
Bonjour,
la séquence à utiliser pour compiler les fichiers est latex - dvips - ps2pdf.
Je suppose que tu utilises pdflatex.
Dis moi si ma remarque est pertinente.
Cordialement,

Re: Problème de compliation latex

Publié : 16 mars 2016, 19:54
par MikFich
Bonsoir et merci pour ta réponse.

En fait lorsque je compile j'utilise le build de sublime text 3 ou de TeXStudio.

Je m'aperçois aussi que ça fonctionne (le pdf est généré) lorsqu'il n'y a pas de figures dans le document, avec toutefois ce log :

Code : Tout sélectionner

[Compiling D:\Skolaj\Matematik\Pyromaths\poell1.tex]

TraditionalBuilder: Engine: pdflatex. Invoking latexmk... done.

Errors:

c:/texlive/2015/texmf-dist/tex/latex/hyperref/hyperref.sty:4319: Package hyperref Error: Wrong DVI mode driver option `ps2pdf', [\ProcessKeyvalOptions{Hyp}]

Warnings:

c:/texlive/2015/texmf-dist/tex/latex/etex-pkg/etex.sty: Package etex Warning: Extended allocation already in use.
./poell1.tex:125: LaTeX Warning: Reference `LastPage' on page 1 undefined on input line 125.
./poell1.tex: Package rerunfilecheck Warning: File `poell1.out' has changed.
./poell1.tex: LaTeX Warning: There were undefined references.
./poell1.tex: LaTeX Warning: Label(s) may have changed. Rerun to get cross-references right.


[Done!]
Lorsque je tape la commande que tu me suggères, voilà ce que j'obtiens :

Code : Tout sélectionner

D:\Skolaj\Matematik\Pyromaths>latex - dvips - ps2pdf poell.tex
This is pdfTeX, Version 3.14159265-2.6-1.40.16 (TeX Live 2015/W32TeX) (preloaded
 format=latex)
 restricted \write18 enabled.
entering extended mode
! I can't find file `-'.
<*> -
      dvips - ps2pdf ./poell.tex
(Press Enter to retry, or Control-Z to exit)
Please type another input file name:
Merci encore pour la rapidité de ta réponse.

Cordialement,

Mikael

Re: Problème de compliation latex

Publié : 16 mars 2016, 20:34
par Jérôme
Bonsoir,
en utilisant
latexmk -pdfps exercices.tex
ça devrait fonctionner.
Je ne sais pas comment intégrer cela à tes logiciels, mais ça doit se trouver sur l'internet.
Bonne soirée.

Re: Problème de compliation latex

Publié : 16 mars 2016, 20:52
par MikFich
Ca semble fonctionner comme ça, merci beaucoup.

Si je trouve une solution pour intégrer ça dans sublime text, je posterai

A+

Mikael

Re: Problème de compliation latex

Publié : 16 mars 2016, 20:59
par Jérôme
Super. Merci d'avoir répondu.

Re: Problème de compliation latex

Publié : 18 mars 2016, 15:08
par MikFich
Bonjour,

Voici ce que j'ai pu trouvé et changé dans sublime text 3, ça à l'air de fonctionner.

Dans le fichier C:\Users\(Nom d'utilisateur)\AppData\Roaming\Sublime Text 3\Packages\LaTeXTools\builders\traditionalBuilder.py

Code : Tout sélectionner

      93		for i, c in enumerate(cmd):
		94		cmd[i] = c.replace(
		95			"-%E", "-" + engine if texify or engine != 'pdflatex' else '-pdfps'
		96		).replace("%E", engine)
Pour moi la ligne à modifier est la n°95.

Enregistrer et redémarrer sublime text.

A+

Mikael