[Résolu] Installation 14.06 avec ubuntu 12.04 impossible

Pour les problèmes liés à l'installation et au fonctionnement de Pyromaths.

Modérateur : Développeurs

zimbo81

[Résolu] Installation 14.06 avec ubuntu 12.04 impossible

Message par zimbo81 » 27 janv. 2015, 22:48

Bonsoir

je suis surpris de ne pouvoir installer la version 14.06. Apparemment un pb de dépendances; Or j'ai bien essayé de forcer l'installation d'une ancienne version mais le système me signale des paquets cassés. Comment réparer pour procéder à une installation correcte ?

Merci d'avance pour votre aide

Avatar de l’utilisateur
Jérôme
Administrateur - Site Admin
Messages : 1083
Inscription : 26 août 2006, 13:10
Localisation : Nantes
Contact :

Re: Installation 14.06 avec ubuntu 12.04 impossibl

Message par Jérôme » 28 janv. 2015, 13:17

Bonjour,
j'aurais besoin d'un peu plus d'informations. pouvez-vous me dire quels sont les messages d'erreurs ? Quel problème de dépendance ?
Merci
Pyromaths génère des fiches d'exercices et leur corrigé en toute simplicité.
Un programme multi-plateformes libre et gratuit sous licence GPL

zimbo81

Re: Installation 14.06 avec ubuntu 12.04 impossibl

Message par zimbo81 » 28 janv. 2015, 18:16

voici ce que j'obtiens après avoir lancé pyromaths en console

Code : Tout sélectionner

Traceback (most recent call last):
  File "/usr/bin/pyromaths", line 15, in <module>
    pyromaths.main()
  File "/usr/lib/python2.7/dist-packages/pyromaths/pyromaths.py", line 60, in main
    pyromaths = StartQT4()
  File "/usr/lib/python2.7/dist-packages/pyromaths/pyromaths.py", line 43, in __init__
    self.ui.setupUi(self)
  File "/usr/lib/python2.7/dist-packages/pyromaths/interface.py", line 150, in setupUi
    self.nom_fichier.setText(self.config['nom_fichier'])
TypeError: QLineEdit.setText(QString): argument 1 has unexpected type 'NoneType'
Erreur de segmentation (core dumped)

zimbo81

Re: Installation 14.06 avec ubuntu 12.04 impossibl

Message par zimbo81 » 29 janv. 2015, 10:54

Code : Tout sélectionner

Erreur : La dépendance ne peut être satisfaite : python (>= 2.7.5-5~)
c'est le message que j'obtiens en installant la 14.06 avec gdebi plutôt que par la logithèque

Avatar de l’utilisateur
Jérôme
Administrateur - Site Admin
Messages : 1083
Inscription : 26 août 2006, 13:10
Localisation : Nantes
Contact :

Re: Installation 14.06 avec ubuntu 12.04 impossibl

Message par Jérôme » 29 janv. 2015, 13:39

Bonjour,
en utilisant la méthode décrite ici :http://www.pyromaths.org/installer/inst ... ion-linux/ et en installant la version 13.03 ou 11.05 ainsi :
sudo apt-get install pyromaths=13.03-1
ou
sudo apt-get install pyromaths=11.05.1b2-0ubuntu1
est-ce que ça passe ?
Pyromaths génère des fiches d'exercices et leur corrigé en toute simplicité.
Un programme multi-plateformes libre et gratuit sous licence GPL

zimbo81

Re: Installation 14.06 avec ubuntu 12.04 impossibl

Message par zimbo81 » 30 janv. 2015, 09:27

Bonjour

En fait il y avait un répertoire /pyromaths dans .config/. J'ai regardé le pyromaths.xml et j'ai vu qu'il correspondait à une ancienne version.
J'ai effacé complètement le répertoire et relancé pyromaths.

ça fonctionne mais je n'ai que la version 11.05 dans synaptic (comme dans la logithèque).

un apt-get update , uograde ou dist-upgrade ne changent rien.

Si j'ai bien compris, les versions se trouvent dans les dépôts d'Ubuntu donc pas besoin de passer par l'ajout d'une nouvelle source en l'occurence http://www.pyromaths.org/debs/ ?

Est-ce bien cela ?

Je voudrais éviter une installation à partir du .deb mais point de 14.06 dans la logithèque...

zimbo81

Re: Installation 14.06 avec ubuntu 12.04 impossibl

Message par zimbo81 » 30 janv. 2015, 09:52

Bon...

l'installation de la version 14.06 avec gdebi renvoie l'erreur

Code : Tout sélectionner

 Erreur : La dépendance ne peut être satisfaite : python (>= 2.7.5-5~)
L'installation toujours avec gdebi de la 13.03 fonctionne; il en est de même pour la 14.05.

Reste que :

1/ seule la 11.05 figure dans ma logithèque

2/ la 14.06 ne fonctionne pas pour des raisons de dépendances non satisfaites

zimbo81

Re: Installation 14.06 avec ubuntu 12.04 impossibl [Résolu]

Message par zimbo81 » 30 janv. 2015, 13:56

Finalement même la 14.10 fonctionne.
Il n'y a donc que la 14.06 que je n'ai pas pu installer.
Inexpliquable...

En tous cas tout fonctionne et c'est un vrai régal d'utiliser cette application

Avatar de l’utilisateur
Jérôme
Administrateur - Site Admin
Messages : 1083
Inscription : 26 août 2006, 13:10
Localisation : Nantes
Contact :

Re: Installation 14.06 avec ubuntu 12.04 impossibl

Message par Jérôme » 30 janv. 2015, 15:34

Je ne prendrai pas le temps de chercher pourquoi la 14.06 ne fonctionne pas. Je suis heureux que tu t'en sois sorti et que ça te plaise.

Concernant le dépôt officiel Ubuntu, il n'est pas à jour. Le mieux est de suivre la procédure indiquée plus haut pour avoir la mise à jour automatique de Pyromaths quand une nouvelle version paraît (ce qui ne devrait plus tarder).
Pyromaths génère des fiches d'exercices et leur corrigé en toute simplicité.
Un programme multi-plateformes libre et gratuit sous licence GPL

zimbo81

Re: Installation 14.06 avec ubuntu 12.04 impossibl

Message par zimbo81 » 31 janv. 2015, 10:31

Merci en tous cas.

Comment mettre en résolu sur le 1er message ?

Avatar de l’utilisateur
Jérôme
Administrateur - Site Admin
Messages : 1083
Inscription : 26 août 2006, 13:10
Localisation : Nantes
Contact :

Re: Installation 14.06 avec ubuntu 12.04 impossibl

Message par Jérôme » 31 janv. 2015, 10:44

Tu cliques sur Éditer dans le premier message et tu modifies le titre.
Pyromaths génère des fiches d'exercices et leur corrigé en toute simplicité.
Un programme multi-plateformes libre et gratuit sous licence GPL

Répondre