Version 14.06

Répondre


Veuillez compléter la vérification suivante afin de nous permettre de nous prémunir contre les soumissions automatisées et intensives effectuées par des robots malveillants.
Émoticônes
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:
Plus d’émoticônes

Le BBCode est activé
La balise [img] est activée
La balise [flash] est désactivée
La balise [url] est activée
Les émoticônes sont activées

Relecture du sujet
   

Agrandir Relecture du sujet : Version 14.06

Re: Version 14.06

par Jérôme » 13 juin 2014, 19:06

Merci Yves. Je n'aime pas trop ce genre d'erreurs... J'ai configuré le serveur pour recevoir un mail si jamais ça devait se reproduire, avec les infos de DEBUG.

Re: Version 14.06

par Yves » 13 juin 2014, 17:26

Je viens de refaire un essai et c'est fonctionnel à présent. J'avais l'erreur quel que soit l'exercice sélectionné. À surveiller…

Re: Version 14.06

par Jérôme » 13 juin 2014, 17:17

Yves a écrit : Par contre, il y a un soucis avec la version en ligne:
UnicodeEncodeError at /creer_fiches/
'ascii' codec can't encode character u'\xe8' in position 14: ordinal not in range(128)
Ça n'est pas possible, il y a toujours un truc qui ne va pas ! :? Peux-tu me dire sur quel exercice tu as obtenu cette réponse, car je n'ai pas cette erreur.

Re: Version 14.06

par Yves » 13 juin 2014, 11:35

Cette fois, j'ai bien eu le mail :D

Par contre, il y a un soucis avec la version en ligne:
UnicodeEncodeError at /creer_fiches/
'ascii' codec can't encode character u'\xe8' in position 14: ordinal not in range(128)

Re: Version 14.06

par Jérôme » 13 juin 2014, 11:15

Yves a écrit :Je viens de réaliser que je ne surveillais pas ce sujet :oops:
:D :D :D On dirait du Arnaud... :lol:

Re: Version 14.06

par Yves » 13 juin 2014, 08:37

Apparemment, les deux possibilités existent…

Je viens de réaliser que je ne surveillais pas ce sujet :oops: si tu as reçu un mail, c'est que tout fonctionne à nouveau ! Bravo pour ce correctif.

Re: Version 14.06

par Jérôme » 12 juin 2014, 23:30

"Au temps pour moi", il me semble. J'ai bien modifié la configuration du serveur également, c'est donc peut-être pour cela que ça fonctionne à présent (sans doute même).
Quant à moi, j'ai reçu un mail m'informant que tu avais posté un message. je vais donc me coucher heureux ! :)

Re: Version 14.06

par Yves » 12 juin 2014, 23:28

J'ai vidé le cache de mon navigateur et il n'y a plus de soucis ! Autant pour moi. Pour les mails, je n'ai rien eu pour l'instant.

Re: Version 14.06

par Jérôme » 12 juin 2014, 23:18

Peux-tu me dire si c'est corrigé ? Et si tu reçois les mails ?
Merci

Re: Version 14.06

par Jérôme » 12 juin 2014, 23:06

Alors là, je suis embêté, car ce n'est pas le cas chez moi...

Re: Version 14.06

par Yves » 12 juin 2014, 22:54

Merci pour cette correction !

Tant qu'on y est, un autre soucis:

Le lien http://forum.pyromaths.org (accessible depuis la page d'accueil) ne renvoie pas sur index.php et un message générique est affiché à la place du forum !

Re: Version 14.06

par Jérôme » 12 juin 2014, 22:42

C'est corrigé. J'avais ajouté une application au sein de Django qui supprimait les lignes vides dans les pages html générées. Je trouvais ça plus joli... Mais ça met le bazar dans textile. Je l'ai donc virée.
Je cherche toujours à comprendre l'origine de mes problèmes avec les mails.

Re: Version 14.06

par Yves » 12 juin 2014, 21:38

Merci Jérôme. C'est beaucoup mieux !

Il reste quelques petits soucis, les sauts de lignes ne sont pas mémorisés (il faut les remettre à la main à chaque nouvelle édition de l'article) et les balises de titre en Textile ne sont pas reconnues (h4. par exemple) :

Image

Re: Version 14.06

par Jérôme » 12 juin 2014, 18:43

merci Yves pour ta recherche. J'ai effectué les modifications nécessaires sur le serveur Apache. Tout est rentré dans l'ordre. J'ai remis les sauts de lignes nécessaires dans ton article et je crois qu'il est à présent tout beau. :)

Re: Version 14.06

par Yves » 11 juin 2014, 18:18

Je viens de regarder le code source de la page avec l'éditeur. La plupart des scripts javascripts ou feuille de style CSS, appelés dans l'en-tête, ont une adresse qui n'est pas valide, ce qui explique les dysfonctionnements actuels.

L'éditeur utilisé actuellement, c'est markItUp! avec le language Textile. D'après leur site web, on peut aussi utiliser markItUp! avec du html.

Haut