[Résolu] Pb affichage des caractères autres que numériques

Pour les problèmes liés à l'installation et au fonctionnement de Pyromaths.

Modérateur: Développeurs

[Résolu] Pb affichage des caractères autres que numériques

Messagede Paparequin » Jeu 28 Fév 2013, 14:57

Bonjour,

Je suis sous Xubuntu 12.10. J'ai installé Pyromaths à partir des dépôts. Ca fonctionne bien...
Sauf que les caractères autres que numériques ne s'affichent pas dans le pdf. C'est ennuyeux. :(

Par ailleurs, lorsque j'ouvre directement le fichier exercices.tex avec Gummi, j'ai aussi un message d'erreur. Ils me disent d'aller voir dans le log de construction, mais je ne comprends rien. :?

Je me dis qu'il y a un problème de codage de caractères. En effet, quand je lance Pyromaths à partir du terminal, j'ai les indications suivantes :
Entity: line 12: parser error : Input is not proper UTF-8, indicate encoding !
Bytes: 0xE9 0xE9 0x73 0x20
t='application/pdf'><dc:title><rdf:Alt><rdf:li xml:lang='x-default'>Exercices cr
^

Est-ce que quelqu'un comprend quelquechose et pourrait m'aider ??
Merci.

--Gilles
Dernière édition par Paparequin le Lun 11 Mar 2013, 13:15, édité 1 fois.
Paparequin
 
Messages: 4
Inscription: Jeu 28 Fév 2013, 14:42

Re: Problème affichage des caractères autres que numériques

Messagede Jérôme » Ven 01 Mar 2013, 19:54

Bonjour,
quel est le lecteur de pdf sous XUbuntu ?
Pyromaths génère des fiches d'exercices et leur corrigé en toute simplicité.
Un programme multi-plateformes libre et gratuit sous licence GPL
Avatar de l’utilisateur
Jérôme
Administrateur - Site Admin
 
Messages: 1067
Inscription: Sam 26 Aoû 2006, 13:10
Localisation: Nantes

Re: Problème affichage des caractères autres que numériques

Messagede Paparequin » Ven 01 Mar 2013, 21:00

J'utilise evince.

--Gilles
Paparequin
 
Messages: 4
Inscription: Jeu 28 Fév 2013, 14:42

Re: Problème affichage des caractères autres que numériques

Messagede Jérôme » Dim 03 Mar 2013, 11:43

Bonjour,
le problème ne semble pas lié à Pyromaths car les fichiers pdf se compilent manifestement. Ce serait plutôt un problème de polices qui ne s'affichent pas dans evince. Le message d'erreur cité plus haut est dû à un vieux bug de ghostscript qui reste sans effet. J'ai le même message mais cela n'empêche en rien l'affichage correct des documents pdf.
Vous pouvez essayer d'installer xpdf pour voir si ça s'affiche convenablement dedans. Si ça ne fonctionne toujours pas, on essaiera de trouver une autre solution.
Jérôme

EDIT : peux-tu essayer de réinstaller texlive-fontsextra ? Et vérifier si un message d'erreur survient ?
Code: Tout sélectionner
sudo apt-get --reinstall install texlive-fontsextra
Pyromaths génère des fiches d'exercices et leur corrigé en toute simplicité.
Un programme multi-plateformes libre et gratuit sous licence GPL
Avatar de l’utilisateur
Jérôme
Administrateur - Site Admin
 
Messages: 1067
Inscription: Sam 26 Aoû 2006, 13:10
Localisation: Nantes

Re: Problème affichage des caractères autres que numériques

Messagede Arnaud » Dim 03 Mar 2013, 11:53

Correction de la commande, il manque un tiret :

Jérôme a écrit:EDIT : peux-tu essayer de réinstaller texlive-fonts-extra ? Et vérifier si un message d'erreur survient ?
Code: Tout sélectionner
sudo apt-get --reinstall install texlive-fonts-extra
Avatar de l’utilisateur
Arnaud
Critique officiel de pyromaths
 
Messages: 603
Inscription: Sam 26 Aoû 2006, 21:49
Localisation: Allemagne

Re: Problème affichage des caractères autres que numériques

Messagede Jérôme » Dim 03 Mar 2013, 11:54

Ah oui, merci ;)
Pyromaths génère des fiches d'exercices et leur corrigé en toute simplicité.
Un programme multi-plateformes libre et gratuit sous licence GPL
Avatar de l’utilisateur
Jérôme
Administrateur - Site Admin
 
Messages: 1067
Inscription: Sam 26 Aoû 2006, 13:10
Localisation: Nantes

Re: Problème affichage des caractères autres que numériques

Messagede djinn » Dim 03 Mar 2013, 12:28

Salut à tous,

J'ai le même problème que Gilles (sous Ubuntu 12.10).
Pour info: réinstaller texlive-fonts-extra ne répare pas le problème chez moi.
Avatar de l’utilisateur
djinn
 
Messages: 183
Inscription: Dim 03 Mar 2013, 11:38

Re: Problème affichage des caractères autres que numériques

Messagede Jérôme » Dim 03 Mar 2013, 12:33

Aïe! Et il n'y a pas de message d'erreur ?
Pyromaths génère des fiches d'exercices et leur corrigé en toute simplicité.
Un programme multi-plateformes libre et gratuit sous licence GPL
Avatar de l’utilisateur
Jérôme
Administrateur - Site Admin
 
Messages: 1067
Inscription: Sam 26 Aoû 2006, 13:10
Localisation: Nantes

Re: Problème affichage des caractères autres que numériques

Messagede djinn » Dim 03 Mar 2013, 12:40

Jérôme a écrit:Aïe! Et il n'y a pas de message d'erreur ?

Pas de message d'erreur à la réinstallation chez moi (je t'épargne le log fastidieux!).
Avatar de l’utilisateur
djinn
 
Messages: 183
Inscription: Dim 03 Mar 2013, 11:38

Re: Problème affichage des caractères autres que numériques

Messagede Arnaud » Dim 03 Mar 2013, 12:42

J'ai souvent eu des soucis avec evince. Est-ce que l'un d'entre vous pourrait confirmer que le problème est présent sous un autre lecteur pdf ?
Avatar de l’utilisateur
Arnaud
Critique officiel de pyromaths
 
Messages: 603
Inscription: Sam 26 Aoû 2006, 21:49
Localisation: Allemagne

Re: Problème affichage des caractères autres que numériques

Messagede djinn » Dim 03 Mar 2013, 12:53

Arnaud a écrit:J'ai souvent eu des soucis avec evince. Est-ce que l'un d'entre vous pourrait confirmer que le problème est présent sous un autre lecteur pdf ?

xpdf plante:
Code: Tout sélectionner
***** Annotations
Erreur de segmentation (core dumped)

Par contre MuPDF fonctionne!
Avatar de l’utilisateur
djinn
 
Messages: 183
Inscription: Dim 03 Mar 2013, 11:38

Re: Problème affichage des caractères autres que numériques

Messagede djinn » Dim 03 Mar 2013, 13:06

Mmh, xpdf plante aussi avec des PDF qui ne viennent pas de Pyromaths (je viens juste d'installer xpdf). Rien à voir avec notre problème.
Par contre, j'aimerais bien pouvoir utiliser Evince…
Avec Evince, je n'arrive pas à avoir de log plus complet: il faudrait une version compilée avec debug.
Par contre, en regardant les propriétés du PDF, je remarque que l'onglet "Polices" indique plusieurs polices "Sans nom" (Type 3, Codage: Custom, Intégré). Indice?
Avatar de l’utilisateur
djinn
 
Messages: 183
Inscription: Dim 03 Mar 2013, 11:38

Re: Problème affichage des caractères autres que numériques

Messagede djinn » Dim 03 Mar 2013, 13:41

Voilà le log de Gummi: http://pastebin.com/WXp9k36w

On note notamment à la fin:
Code: Tout sélectionner
(/usr/share/texlive/texmf-dist/tex/latex/latexconfig/hyperref.cfg
File: hyperref.cfg 2002/06/06 v1.2 hyperref configuration of TeXLive
)
Package hyperref Info: Option `bookmarks' set `true' on input line 3941.
Package hyperref Info: Option `bookmarksnumbered' set `true' on input line 3941.
 
/usr/share/texlive/texmf-dist/tex/latex/hyperref/hyperref.sty:3941: Package hyp
erref Error: Wrong DVI mode driver option `ps2pdf',
(hyperref)                because pdfTeX or LuaTeX is running in PDF mode.
 
See the hyperref package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                             
                                                 
l.3941 \ProcessKeyvalOptions{Hyp}
                               
(...)
/usr/share/texlive/texmf-dist/tex/latex/hyperref/hyperref.sty:3941:  ==> Fatal
error occurred, no output PDF file produced!
Avatar de l’utilisateur
djinn
 
Messages: 183
Inscription: Dim 03 Mar 2013, 11:38

Re: Problème affichage des caractères autres que numériques

Messagede djinn » Dim 03 Mar 2013, 14:08

Avec Gummi, il y a progrès en modifiant les options de compilation du document: TeX->DVI(->PS)->PDF.
Le document (exercices.tex) est compilé est affiché dans l'aperçu, avec les mêmes caractéristiques qu'evince: pas de caractères alphanumériques, à part les titres d'exercices ("Exercice 1" par ex.).
Image
Avatar de l’utilisateur
djinn
 
Messages: 183
Inscription: Dim 03 Mar 2013, 11:38

Re: Problème affichage des caractères autres que numériques

Messagede Arnaud » Dim 03 Mar 2013, 14:31

Cela ressemble au problème que j'ai eu il y a quelques mois : viewtopic.php?f=22&t=226
Suite à de nombreuses recherches : rien, à part que cela semble provenir de libpoppler ( elle-même basée sur xpdf ).

Ma solution, pas satisfaisante en raison des dépendances et du fait que cela ne résout pas le problème, a été de passer à okular.
Depuis ce jour, plus rien à signaler.
Avatar de l’utilisateur
Arnaud
Critique officiel de pyromaths
 
Messages: 603
Inscription: Sam 26 Aoû 2006, 21:49
Localisation: Allemagne

Suivante

Retourner vers Installation et fonctionnement

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités